RxJSに関するエラーModule not found: Error: Can’t resolve

angular-icon

Angular5でRxJSをインポートしようとした時に大量のエラーが。
angular-module-not-found-error
どうやらうまく読まれていない様子。
ググってみるとこんなページが。
その中でこれを見ろとのこと。
solving-document-link-angular-rxjs-error
すると、RxJSのバージョンをアップデートするとよさげでした。
rxjs6-install-command
ただ互換性の問題からcompatも一緒にインストールしたらよさそうだったので四角でかこった部分のコマンドでrxjs6とrxjs-compatをインストールしました。
するとえらーがなくなりましたとさ。
うん、バージョンって難しい。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です